blob: 7fc3eef91b97676c5cee139fd4e63a4ca4d8e0e8 [file] [log] [blame]
Andrew Geisslerc5535c92023-01-27 16:10:19 -06001SUMMARY = "A simple, correct PEP517 package builder"
2HOMEPAGE = "https://github.com/pypa/build"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=310439af287b0fb4780b2ad6907c256c"
5
Patrick Williamsb58112e2024-03-07 11:16:36 -06006SRC_URI[sha256sum] = "8eea65bb45b1aac2e734ba2cc8dad3a6d97d97901a395bd0ed3e7b46953d2a31"
Andrew Geisslerc5535c92023-01-27 16:10:19 -06007
8inherit pypi python_flit_core
9
10DEPENDS += "python3-pyproject-hooks-native"
11
12DEPENDS:remove:class-native = "python3-build-native"
13
14# Skip dependencies as we're doing a minimal build to bootstrap
15PEP517_BUILD_OPTS:class-native = "--skip-dependency-check"
16
17do_compile:prepend:class-native() {
18 export PYTHONPATH="${S}/src"
19}
20
Patrick Williams8e7b46e2023-05-01 14:19:06 -050021RDEPENDS:${PN} += " \
22 python3-compression \
23 python3-difflib \
24 python3-ensurepip \
25 python3-logging \
26 python3-packaging \
27 python3-pyproject-hooks \
28 python3-tomllib \
29 python3-venv \
30"
Andrew Geisslerc5535c92023-01-27 16:10:19 -060031
32BBCLASSEXTEND = "native nativesdk"