Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "A cross-platform process and system utilities module for Python" |
| 2 | LICENSE = "BSD-3-Clause" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a9c72113a843d0d732a0ac1c200d81b1" |
| 4 | HOMEPAGE = "https://pypi.org/project/psutil/" |
| 5 | |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 6 | SRC_URI[sha256sum] = "6be126e3225486dff286a8fb9a06246a5253f4c7c53b475ea5f5ac934e64194c" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 7 | |
| 8 | inherit pypi setuptools3 |
| 9 | |
| 10 | PACKAGES =+ "${PN}-tests" |
| 11 | |
| 12 | FILES:${PN}-tests += " \ |
| 13 | ${PYTHON_SITEPACKAGES_DIR}/psutil/test* \ |
| 14 | ${PYTHON_SITEPACKAGES_DIR}/psutil/__pycache__/test* \ |
| 15 | " |
| 16 | |
| 17 | |
| 18 | RDEPENDS:${PN} += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 19 | python3-shell \ |
| 20 | python3-threading \ |
| 21 | python3-xml \ |
| 22 | python3-netclient \ |
| 23 | python3-ctypes \ |
| 24 | python3-resource \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 25 | " |
| 26 | |
| 27 | RDEPENDS:${PN}-tests += " \ |
| 28 | ${PN} \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 29 | python3 \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 30 | coreutils \ |
| 31 | procps \ |
| 32 | binutils \ |
| 33 | gcc \ |
| 34 | gcc-symlinks \ |
| 35 | libstdc++ \ |
| 36 | libstdc++-dev \ |
| 37 | " |
| 38 | |
| 39 | INSANE_SKIP:${PN}-tests += "dev-deps" |
| 40 | |
| 41 | BBCLASSEXTEND = "native" |