Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "Python parsing module" |
| 2 | DESCRIPTION = "The pyparsing module is an alternative approach to creating \ |
| 3 | and executing simple grammars, vs. the traditional lex/yacc approach, or \ |
| 4 | the use of regular expressions. The pyparsing module provides a library of \ |
| 5 | classes that client code uses to construct the grammar directly in Python \ |
| 6 | code." |
| 7 | HOMEPAGE = "https://github.com/pyparsing/pyparsing/" |
| 8 | BUGTRACKER = "https://github.com/pyparsing/pyparsing/issues" |
| 9 | |
| 10 | LICENSE = "MIT" |
| 11 | LIC_FILES_CHKSUM = "file://LICENSE;md5=657a566233888513e1f07ba13e2f47f1" |
| 12 | |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 13 | SRC_URI[sha256sum] = "ede28a1a32462f5a9705e07aea48001a08f7cf81a021585011deba701581a0db" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 14 | |
| 15 | UPSTREAM_CHECK_REGEX = "pyparsing-(?P<pver>.*)\.tar" |
| 16 | |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 17 | inherit pypi python_flit_core |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 18 | |
| 19 | RDEPENDS:${PN} += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 20 | python3-datetime \ |
| 21 | python3-debugger \ |
| 22 | python3-html \ |
| 23 | python3-json \ |
| 24 | python3-netclient \ |
| 25 | python3-pprint \ |
| 26 | python3-stringold \ |
| 27 | python3-threading \ |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 28 | " |
| 29 | |
| 30 | BBCLASSEXTEND = "native nativesdk" |