blob: 6abed1205fdd0be16c7000768dea520049ee78f6 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Python implementation of a sliding window memory map manager"
2DESCRIPTION = "A pure Python implementation of a sliding memory map to \
3help unifying memory mapped access on 32 and 64 bit systems and to help \
4managing resources more efficiently."
5HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
6SECTION = "devel/python"
7LICENSE = "BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e910b35b0ef4e1f665b9a75d6afb7709"
9
10inherit pypi setuptools3
11
12PYPI_PACKAGE = "smmap"
13
Andrew Geissler220dafd2023-10-04 10:18:08 -050014SRC_URI[sha256sum] = "8d79028ea6cc131da5eab099a5d95a998d43c6779956fffe3b455040911076da"
Andrew Geisslereff27472021-10-29 15:35:00 -050015
Patrick Williams73bd93f2024-02-20 08:07:48 -060016RDEPENDS:${PN} += "python3-codecs \
17 python3-mmap \
Andrew Geisslereff27472021-10-29 15:35:00 -050018"
19BBCLASSEXTEND = "native nativesdk"