Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Checksumming Copy on Write Filesystem utilities" |
| 2 | DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \ |
| 3 | implementing advanced features while focusing on fault tolerance, repair and \ |
| 4 | easy administration. \ |
| 5 | This package contains utilities (mkfs, fsck, btrfsctl) used to work with \ |
| 6 | btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3." |
| 7 | |
| 8 | HOMEPAGE = "https://btrfs.wiki.kernel.org" |
| 9 | |
| 10 | LICENSE = "GPLv2" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067" |
| 12 | SECTION = "base" |
| 13 | DEPENDS = "util-linux attr e2fsprogs lzo acl" |
| 14 | DEPENDS_append_class-target = " udev" |
| 15 | RDEPENDS_${PN} = "libgcc" |
| 16 | |
Andrew Geissler | 9b4d8b0 | 2021-02-19 12:26:16 -0600 | [diff] [blame] | 17 | SRCREV = "f2ffce38b9c1477a7350bfe165f0e34b9bde40f5" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 18 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \ |
| 19 | file://0001-Add-a-possibility-to-specify-where-python-modules-ar.patch \ |
| 20 | " |
| 21 | |
| 22 | PACKAGECONFIG ??= "python" |
| 23 | PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, asciidoc-native xmlto-native" |
| 24 | PACKAGECONFIG[python] = "--enable-python,--disable-python,python3-setuptools-native" |
| 25 | PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd" |
| 26 | |
| 27 | inherit autotools-brokensep pkgconfig manpages |
| 28 | inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'distutils3-base', '', d)} |
| 29 | |
| 30 | CLEANBROKEN = "1" |
| 31 | |
| 32 | EXTRA_OECONF_append_libc-musl = " --disable-backtrace " |
| 33 | EXTRA_PYTHON_CFLAGS = "${DEBUG_PREFIX_MAP}" |
| 34 | EXTRA_PYTHON_CFLAGS_class-native = "" |
| 35 | EXTRA_PYTHON_LDFLAGS = "${LDFLAGS}" |
| 36 | EXTRA_OEMAKE = "V=1 'EXTRA_PYTHON_CFLAGS=${EXTRA_PYTHON_CFLAGS}' 'EXTRA_PYTHON_LDFLAGS=${EXTRA_PYTHON_LDFLAGS}'" |
| 37 | |
| 38 | do_configure_prepend() { |
| 39 | # Upstream doesn't ship this and autoreconf won't install it as automake isn't used. |
| 40 | mkdir -p ${S}/config |
| 41 | cp -f $(automake --print-libdir)/install-sh ${S}/config/ |
| 42 | } |
| 43 | |
| 44 | S = "${WORKDIR}/git" |
| 45 | |
| 46 | do_install_append() { |
| 47 | if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then |
| 48 | oe_runmake 'DESTDIR=${D}' 'PYTHON_SITEPACKAGES_DIR=${PYTHON_SITEPACKAGES_DIR}' install_python |
| 49 | fi |
| 50 | } |
| 51 | |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 52 | BBCLASSEXTEND = "native nativesdk" |