Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "File type identification using libmagic" |
| 2 | DESCRIPTION = "This module uses ctypes to access the libmagic file type \ |
| 3 | identification library. It makes use of the local magic database and supports \ |
| 4 | both textual and MIME-type output." |
| 5 | HOMEPAGE = "http://github.com/ahupp/python-magic" |
| 6 | |
| 7 | LICENSE = "MIT" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=61495c152d794e6be5799a9edca149e3" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 9 | |
| 10 | PYPI_PACKAGE = "python-magic" |
| 11 | |
| 12 | inherit pypi setuptools3 |
| 13 | |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 14 | SRC_URI[sha256sum] = "ca884349f2c92ce830e3f498c5b7c7051fe2942c3ee4332f65213b8ebff15a62" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 16 | RDEPENDS_${PN} += "file \ |
| 17 | ${PYTHON_PN}-ctypes \ |
| 18 | ${PYTHON_PN}-io \ |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 19 | ${PYTHON_PN}-logging \ |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 20 | ${PYTHON_PN}-shell" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 21 | |
| 22 | BBCLASSEXTEND = "native" |