Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Python GObject bindings" |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 2 | HOMEPAGE = "https://gitlab.gnome.org/GNOME/pygobject" |
| 3 | DESCRIPTION = "PyGObject is a Python package which provides bindings for GObject based libraries such as GTK, GStreamer, WebKitGTK, GLib, GIO and many more." |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 4 | SECTION = "devel/python" |
| 5 | LICENSE = "LGPLv2.1" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7" |
| 7 | |
| 8 | GNOMEBASEBUILDCLASS = "meson" |
| 9 | inherit gnomebase distutils3-base gobject-introspection upstream-version-is-even |
| 10 | |
| 11 | DEPENDS += "python3 glib-2.0" |
| 12 | |
| 13 | SRCNAME="pygobject" |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 14 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 15 | SRC_URI = " \ |
| 16 | http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \ |
| 17 | file://0001-Do-not-build-tests.patch \ |
| 18 | " |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 19 | SRC_URI[sha256sum] = "0372d1bb9122fc19f500a249b1f38c2bb67485000f5887497b4b205b3e7084d5" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 20 | |
| 21 | UNKNOWN_CONFIGURE_WHITELIST = "introspection" |
| 22 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 23 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
| 24 | |
| 25 | PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', [ 'directfb', 'wayland', 'x11' ], 'cairo', '', d)}" |
| 26 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 27 | RDEPENDS_${PN} += "python3-pkgutil" |
| 28 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 29 | # python3-pycairo is checked on configuration -> DEPENDS |
| 30 | # we don't link against python3-pycairo -> RDEPENDS |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 31 | PACKAGECONFIG[cairo] = "-Dpycairo=enabled,-Dpycairo=disabled, cairo python3-pycairo, python3-pycairo" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 32 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 33 | BBCLASSEXTEND = "native" |
| 34 | PACKAGECONFIG_class-native = "" |