blob: ca4a3eff9147f091af112c215eb699f1bbd2c282 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2DESCRIPTION = "Library provides support for the Tag Image File Format \
3(TIFF), a widely used format for storing image data. This library \
4provide means to easily access and create TIFF image files."
5HOMEPAGE = "http://www.libtiff.org/"
6LICENSE = "BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=a3e32d664d6db1386b4689c8121531c3"
8
9CVE_PRODUCT = "libtiff"
10
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060011SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
Patrick Williamsb542dec2023-06-09 01:26:37 -050012 file://CVE-2022-48281.patch \
13 file://CVE-2023-2731.patch \
14"
Andrew Geissler517393d2023-01-13 08:55:19 -060015
16SRC_URI[sha256sum] = "c7a1d9296649233979fa3eacffef3fa024d73d05d589cb622727b5b08c423464"
17
18# exclude betas
19UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
20
21# Tested with check from https://security-tracker.debian.org/tracker/CVE-2015-7313
22# and 4.3.0 doesn't have the issue
23CVE_CHECK_IGNORE += "CVE-2015-7313"
24# These issues only affect libtiff post-4.3.0 but before 4.4.0,
25# caused by 3079627e and fixed by b4e79bfa.
26CVE_CHECK_IGNORE += "CVE-2022-1622 CVE-2022-1623"
27# Issue is in jbig which we don't enable
28CVE_CHECK_IGNORE += "CVE-2022-1210"
29
30inherit autotools multilib_header
31
32CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
33
34PACKAGECONFIG ?= "cxx jpeg zlib lzma \
35 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
36
37PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
38PACKAGECONFIG[jbig] = "--enable-jbig,--disable-jbig,jbig,"
39PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
40PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
41PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
42PACKAGECONFIG[webp] = "--enable-webp,--disable-webp,libwebp,"
Patrick Williams864cc432023-02-09 14:54:44 -060043PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd,"
44PACKAGECONFIG[libdeflate] = "--enable-libdeflate,--disable-libdeflate,libdeflate,"
Andrew Geissler517393d2023-01-13 08:55:19 -060045
46# Convert single-strip uncompressed images to multiple strips of specified
47# size (default: 8192) to reduce memory usage
48PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
49
50# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
51PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
52
53# Control picking up YCbCr subsample info. Disable to support files lacking
54# the tag
55PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
56
57# Support a mechanism allowing reading large strips (usually one strip files)
58# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
59PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
60
61PACKAGES =+ "tiffxx tiff-utils"
62FILES:tiffxx = "${libdir}/libtiffxx.so.*"
63FILES:tiff-utils = "${bindir}/*"
64
65do_install:append() {
66 oe_multilib_header tiffconf.h
67}
68
69BBCLASSEXTEND = "native nativesdk"