Matt Spinler | 1e3c414 | 2016-08-12 12:52:36 -0500 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC machine readable workbook API modules" |
| 2 | DESCRIPTION = "The API for the MRW XML generated by the Serverwiz tool" |
| 3 | PR = "r1" |
Brad Bishop | edb390a | 2018-11-06 10:09:31 -0800 | [diff] [blame] | 4 | LICENSE = "Apache-2.0" |
Brad Bishop | 0f1b05d | 2018-10-16 11:02:54 -0500 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314" |
Matt Spinler | 1e3c414 | 2016-08-12 12:52:36 -0500 | [diff] [blame] | 6 | |
Brad Bishop | 0f1b05d | 2018-10-16 11:02:54 -0500 | [diff] [blame] | 7 | S = "${WORKDIR}/git" |
Matt Spinler | 1e3c414 | 2016-08-12 12:52:36 -0500 | [diff] [blame] | 8 | |
Matt Spinler | 1e3c414 | 2016-08-12 12:52:36 -0500 | [diff] [blame] | 9 | inherit perlnative |
| 10 | inherit cpan-base |
Matt Spinler | b103a33 | 2016-09-15 10:39:43 -0500 | [diff] [blame] | 11 | inherit mrw-rev |
Joseph Reynolds | 79809ea | 2021-02-26 15:37:31 -0600 | [diff] [blame^] | 12 | inherit native |
Matt Spinler | 1e3c414 | 2016-08-12 12:52:36 -0500 | [diff] [blame] | 13 | |
| 14 | DEPENDS += "libxml-simple-perl-native json-perl-native" |
| 15 | |
Matt Spinler | b103a33 | 2016-09-15 10:39:43 -0500 | [diff] [blame] | 16 | SRC_URI += "${MRW_API_SRC_URI}" |
| 17 | SRCREV = "${MRW_API_SRCREV}" |
Matt Spinler | 1e3c414 | 2016-08-12 12:52:36 -0500 | [diff] [blame] | 18 | |
| 19 | do_install() { |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 20 | install -d ${D}${PERLLIBDIRS_class-native}/site_perl/${PERLVERSION}/mrw |
| 21 | install -m 0755 scripts/Targets.pm ${D}${PERLLIBDIRS_class-native}/site_perl/${PERLVERSION}/mrw/Targets.pm |
Matt Spinler | 1e3c414 | 2016-08-12 12:52:36 -0500 | [diff] [blame] | 22 | } |