Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Incredibly simple helpers for testing code with exceptions" |
| 2 | DESCRIPTION = "Test::Fatal is an alternative to the popular Test::Exception.\ |
| 3 | It does much less, but should allow greater flexibility in testing \ |
| 4 | exception-throwing code with about the same amount of typing." |
| 5 | HOMEPAGE = "https://github.com/rjbs/Test-Fatal" |
| 6 | BUGTRACKER = "https://github.com/rjbs/Test-Fatal/issues" |
| 7 | SECTION = "libs" |
| 8 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" |
| 9 | |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b5c851290cab1dda12fcfb0e9ec43639" |
| 11 | |
| 12 | SRC_URI = "${CPAN_MIRROR}/authors/id/R/RJ/RJBS/Test-Fatal-${PV}.tar.gz" |
| 13 | |
| 14 | SRC_URI[sha256sum] = "37dfffdafb84b762efe96b02fb2aa41f37026c73e6b83590db76229697f3c4a6" |
| 15 | |
| 16 | S = "${WORKDIR}/Test-Fatal-${PV}" |
| 17 | |
| 18 | inherit cpan ptest-perl |
| 19 | |
| 20 | RDEPENDS:${PN} += "\ |
| 21 | libtry-tiny-perl \ |
| 22 | perl-module-carp \ |
| 23 | perl-module-exporter \ |
| 24 | perl-module-test-builder \ |
| 25 | " |
| 26 | |
| 27 | RDEPENDS:${PN}-ptest += "\ |
| 28 | perl-module-extutils-makemaker \ |
| 29 | perl-module-extutils-mm-unix \ |
| 30 | perl-module-file-spec \ |
| 31 | perl-module-overload \ |
| 32 | perl-module-test-builder-tester \ |
| 33 | perl-module-test-more \ |
| 34 | " |
| 35 | |
| 36 | BBCLASSEXTEND = "native nativesdk" |