Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 1 | SUMMARY = "High level compatibility layer for multiple asynchronous event loop implementations" |
| 2 | SECTION = "devel/python" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c0a769411d2af7894099e8ff75058c9f" |
| 5 | |
| 6 | inherit pypi python_setuptools_build_meta |
| 7 | |
| 8 | SRC_URI[sha256sum] = "e1875bb4b4e2de1669f4bc7869b6d3f54231cdced71605e6e64c9be77e3be50f" |
| 9 | |
| 10 | DEPENDS += " \ |
| 11 | python3-setuptools-scm-native \ |
| 12 | " |
| 13 | |
| 14 | # Don't provide "trio" PACKAGECONFIG as nothing provides "python3-trio" currently. |
| 15 | # If somebody needs this please feel free to add python3-trio and enable the |
| 16 | # packageconfig below: |
| 17 | #PACKAGECONFIG ??= "" |
| 18 | #PACKAGECONFIG[trio] = ",,,python3-trio" |
| 19 | |
| 20 | RDEPENDS:${PN} += "\ |
| 21 | python3-idna \ |
| 22 | python3-sniffio \ |
| 23 | " |