blob: 6b74f7260c3787129d2377e33f357b191b6cb79c [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001# Copyright (C) 2021 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Fastest Python implementation of JSON schema"
5HOMEPAGE = "https://github.com/seznam/python-fastjsonschema"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=18950e8362b69c0c617b42b8bd8e7532"
8
Patrick Williams2a254922023-08-11 09:48:11 -05009SRCREV = "756540088687cda351390f687b92e602feaa7dc6"
Patrick Williams92b42cb2022-09-03 06:53:57 -050010PYPI_SRC_URI = "git://github.com/horejsek/python-fastjsonschema;protocol=https;branch=master"
11
12SRC_URI += "file://run-ptest"
13
14inherit ptest pypi setuptools3
15
16S = "${WORKDIR}/git"
17
18do_install_ptest() {
19 install -d ${D}${PTEST_PATH}/tests
20 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
21}
22
23RDEPENDS:${PN}-ptest += "\
24 python3-colorama \
25 python3-jsonschema \
26 python3-pylint \
27 python3-pytest \
28 python3-pytest-benchmark \
29 python3-pytest-cache \
Patrick Williams73bd93f2024-02-20 08:07:48 -060030 python3-unittest-automake-output \
Patrick Williams92b42cb2022-09-03 06:53:57 -050031"
32RDEPENDS:${PN} += "\
33 python3-core \
34 python3-urllib3 \
35 python3-numbers \
36 python3-pickle \
37 python3-json \
38 "
39
40BBCLASSEXTEND = "native nativesdk"