Patrick Williams | 2194f50 | 2022-10-16 14:26:09 -0500 | [diff] [blame] | 1 | SUMMARY = "A coroutine-based Python networking library" |
| 2 | DESCRIPTION = "gevent is a coroutine-based Python networking library that uses greenlet to provide \ |
| 3 | a high-level synchronous API on top of the libevent event loop." |
| 4 | HOMEPAGE = "http://www.gevent.org" |
| 5 | LICENSE = "MIT & Python-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4de99aac27b470c29c6c309e0c279b65" |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 7 | DEPENDS += "python3-greenlet libev libuv c-ares python3-cython-native" |
Patrick Williams | 2194f50 | 2022-10-16 14:26:09 -0500 | [diff] [blame] | 8 | |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 9 | RDEPENDS:${PN} = "python3-greenlet \ |
| 10 | python3-mime \ |
| 11 | python3-pprint \ |
| 12 | python3-zopeevent \ |
| 13 | python3-zopeinterface \ |
Patrick Williams | 2194f50 | 2022-10-16 14:26:09 -0500 | [diff] [blame] | 14 | " |
| 15 | |
| 16 | SRC_URI += "file://0001-_setuputils.py-Do-not-add-sys_inc_dir.patch" |
| 17 | |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 18 | SRC_URI[sha256sum] = "432fc76f680acf7cf188c2ee0f5d3ab73b63c1f03114c7cd8a34cebbe5aa2056" |
Patrick Williams | 2194f50 | 2022-10-16 14:26:09 -0500 | [diff] [blame] | 19 | |
| 20 | inherit pypi setuptools3 |
| 21 | |
| 22 | # Don't embed libraries, link to the system provided libs instead |
| 23 | export GEVENTSETUP_EMBED_CARES = "0" |
| 24 | export GEVENTSETUP_EMBED_LIBEV = "0" |
| 25 | export GEVENTSETUP_EMBED_LIBUV = "0" |
| 26 | |
| 27 | do_configure:append() { |
| 28 | # Delete the embedded copies of libraries so we can't accidentally link to them |
| 29 | rm -rf ${S}/deps |
| 30 | |
| 31 | # Delete the generated cython files, as they are all out of date with python 3.11 |
| 32 | rm -rf ${S}/src/gevent/*.c |
| 33 | } |
| 34 | |
| 35 | do_compile:append() { |
| 36 | sed -i -e 's#${WORKDIR}##g' ${S}/src/gevent/*.c ${S}/src/gevent/libev/*.c ${S}/src/gevent/resolver/*.c |
| 37 | } |