blob: fbdbf8ccc7d6dfa2e4bb97ba1d9fbf8634d032fe [file] [log] [blame]
Patrick Williams2194f502022-10-16 14:26:09 -05001SUMMARY = "A coroutine-based Python networking library"
2DESCRIPTION = "gevent is a coroutine-based Python networking library that uses greenlet to provide \
3a high-level synchronous API on top of the libevent event loop."
4HOMEPAGE = "http://www.gevent.org"
5LICENSE = "MIT & Python-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=4de99aac27b470c29c6c309e0c279b65"
Patrick Williams39653562024-03-01 08:54:02 -06007DEPENDS += "python3-greenlet libev libuv c-ares python3-cython-native"
Patrick Williams2194f502022-10-16 14:26:09 -05008
Patrick Williams39653562024-03-01 08:54:02 -06009RDEPENDS:${PN} = "python3-greenlet \
10 python3-mime \
11 python3-pprint \
12 python3-zopeevent \
13 python3-zopeinterface \
Patrick Williams2194f502022-10-16 14:26:09 -050014 "
15
16SRC_URI += "file://0001-_setuputils.py-Do-not-add-sys_inc_dir.patch"
17
Patrick Williams39653562024-03-01 08:54:02 -060018SRC_URI[sha256sum] = "432fc76f680acf7cf188c2ee0f5d3ab73b63c1f03114c7cd8a34cebbe5aa2056"
Patrick Williams2194f502022-10-16 14:26:09 -050019
20inherit pypi setuptools3
21
22# Don't embed libraries, link to the system provided libs instead
23export GEVENTSETUP_EMBED_CARES = "0"
24export GEVENTSETUP_EMBED_LIBEV = "0"
25export GEVENTSETUP_EMBED_LIBUV = "0"
26
27do_configure:append() {
28 # Delete the embedded copies of libraries so we can't accidentally link to them
29 rm -rf ${S}/deps
30
31 # Delete the generated cython files, as they are all out of date with python 3.11
32 rm -rf ${S}/src/gevent/*.c
33}
34
35do_compile:append() {
36 sed -i -e 's#${WORKDIR}##g' ${S}/src/gevent/*.c ${S}/src/gevent/libev/*.c ${S}/src/gevent/resolver/*.c
37}