blob: e9a9a4fbc5a9de3aabcf24d97b65b679b12cbb5e [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Thin-wrapper around the mock package for easier use with pytest"
2HOMEPAGE = "https://github.com/pytest-dev/pytest-mock/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = " \
5 file://LICENSE;md5=b2ddb1e69238461b7e4ef2a84d874109 \
6"
7
8SRC_URI = " \
9 git://github.com/pytest-dev/pytest-mock;branch=main;protocol=https \
10 file://run-ptest \
11 file://0001-test_pytest_mock-skip-args-introspection-tests.patch \
Patrick Williams73bd93f2024-02-20 08:07:48 -060012 file://403.patch \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060013"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060014SRCREV = "69adc6f76c1a7baf4e7a728da9eec38741d5783e"
15
Patrick Williamsac13d5f2023-11-24 18:59:46 -060016inherit setuptools3 ptest
17
Patrick Williams73bd93f2024-02-20 08:07:48 -060018DEPENDS += "python3-setuptools-scm-native"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060019
20RDEPENDS:${PN} += " \
21 python3-asyncio \
22 python3-pytest \
23 python3-pytest-asyncio \
24 python3-unittest \
Patrick Williams73bd93f2024-02-20 08:07:48 -060025 python3-unittest-automake-output \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060026"
27
28S = "${WORKDIR}/git"
29
30do_install_ptest() {
31 install -d ${D}${PTEST_PATH}/tests
32 cp -rf ${S}/tests ${D}${PTEST_PATH}/
33}