Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Thin-wrapper around the mock package for easier use with pytest" |
| 2 | HOMEPAGE = "https://github.com/pytest-dev/pytest-mock/" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = " \ |
| 5 | file://LICENSE;md5=b2ddb1e69238461b7e4ef2a84d874109 \ |
| 6 | " |
| 7 | |
| 8 | SRC_URI = " \ |
| 9 | git://github.com/pytest-dev/pytest-mock;branch=main;protocol=https \ |
| 10 | file://run-ptest \ |
| 11 | file://0001-test_pytest_mock-skip-args-introspection-tests.patch \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 12 | file://403.patch \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 13 | " |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 14 | SRCREV = "69adc6f76c1a7baf4e7a728da9eec38741d5783e" |
| 15 | |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 16 | inherit setuptools3 ptest |
| 17 | |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 18 | DEPENDS += "python3-setuptools-scm-native" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 19 | |
| 20 | RDEPENDS:${PN} += " \ |
| 21 | python3-asyncio \ |
| 22 | python3-pytest \ |
| 23 | python3-pytest-asyncio \ |
| 24 | python3-unittest \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 25 | python3-unittest-automake-output \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 26 | " |
| 27 | |
| 28 | S = "${WORKDIR}/git" |
| 29 | |
| 30 | do_install_ptest() { |
| 31 | install -d ${D}${PTEST_PATH}/tests |
| 32 | cp -rf ${S}/tests ${D}${PTEST_PATH}/ |
| 33 | } |