blob: 941b5ee0f303a03802537b91e1b2dc0158e69c2c [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Serialization based on ast.literal_eval"
2LICENSE = "MIT"
William A. Kennington IIIb95905d2021-06-02 12:40:56 -07003LIC_FILES_CHKSUM = "file://LICENSE;md5=d7c28f460fafe7be454fcdcac0b60263"
Andrew Geissler82c905d2020-04-13 13:39:40 -05004
Andrew Geissler615f2f12022-07-15 14:00:58 -05005SRC_URI[sha256sum] = "0407035fe3c6644387d48cff1467d5aa9feff814d07372b78677ed0ee3ed7095"
Andrew Geissler82c905d2020-04-13 13:39:40 -05006
7inherit pypi ptest setuptools3
8
9SRC_URI += " \
10 file://run-ptest \
11"
12
Patrick Williams213cb262021-08-07 19:21:33 -050013RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060014 python3-pytest \
15 python3-pytz \
16 python3-unittest-automake-output \
Andrew Geissler82c905d2020-04-13 13:39:40 -050017"
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/tests
21 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}
23
Patrick Williams213cb262021-08-07 19:21:33 -050024RDEPENDS:${PN} += "\
Patrick Williams73bd93f2024-02-20 08:07:48 -060025 python3-netclient \
26 python3-numbers \
27"