blob: b5f6be9f2724584b4fc20827c7ac8438517b559a [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Ultra fast JSON encoder and decoder for Python"
2DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with bindings for Python 2.5+ and 3."
3
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e0039a83d8a99726b5418f0b03302d0a"
6
Patrick Williams169d7bc2024-01-05 11:33:25 -06007SRC_URI[sha256sum] = "89cc92e73d5501b8a7f48575eeb14ad27156ad092c2e9fc7e3cf949f07e75532"
Andrew Geissler517393d2023-01-13 08:55:19 -06008
9inherit pypi ptest setuptools3
10
11SRC_URI += " \
12 file://run-ptest \
13 file://0001-setup.py-Do-not-strip-debugging-symbols.patch \
14"
15
Patrick Williams73bd93f2024-02-20 08:07:48 -060016DEPENDS += "python3-setuptools-scm-native"
Andrew Geissler517393d2023-01-13 08:55:19 -060017
18RDEPENDS:${PN} += "\
Patrick Williams73bd93f2024-02-20 08:07:48 -060019 python3-datetime \
20 python3-numbers \
Andrew Geissler517393d2023-01-13 08:55:19 -060021"
22
23RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060024 python3-json \
25 python3-pytest \
26 python3-pytz \
27 python3-unittest-automake-output \
Andrew Geissler517393d2023-01-13 08:55:19 -060028"
29
30do_install_ptest() {
31 install -d ${D}${PTEST_PATH}/tests
32 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
33}
34
35BBCLASSEXTEND = "native nativesdk"