Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 1 | SUMMARY = "A Python library for interacting with Ethereum." |
| 2 | HOMEPAGE = "https://github.com/ethereum/web3.py" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=373fede350846fdffd23648fba504635" |
| 6 | |
| 7 | SRC_URI[sha256sum] = "f9e7eefc1b3c3d194868a4ef9583b625c18ea3f31a48ebe143183db74898f381" |
| 8 | |
| 9 | inherit pypi setuptools3 |
| 10 | |
| 11 | RDEPENDS:${PN} += " \ |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 12 | python3-aiohttp \ |
| 13 | python3-eth-abi \ |
| 14 | python3-eth-account \ |
| 15 | python3-eth-hash \ |
| 16 | python3-eth-typing \ |
| 17 | python3-eth-utils \ |
| 18 | python3-hexbytes \ |
| 19 | python3-jsonschema \ |
| 20 | python3-protobuf \ |
| 21 | python3-pydantic \ |
| 22 | python3-requests \ |
| 23 | python3-typing-extensions \ |
| 24 | python3-websockets \ |
| 25 | python3-pyunormalize \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 26 | " |