Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Vulkan Header files and API registry" |
| 2 | DESCRIPTION = "Vulkan is a 3D graphics and compute API providing cross-platform access \ |
| 3 | to modern GPUs with low overhead and targeting realtime graphics applications such as \ |
| 4 | games and interactive media. This package contains the development headers \ |
| 5 | for packages wanting to make use of Vulkan." |
| 6 | HOMEPAGE = "https://www.khronos.org/vulkan/" |
| 7 | BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Headers" |
| 8 | SECTION = "libs" |
| 9 | |
| 10 | LICENSE = "Apache-2.0 & MIT" |
| 11 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=1bc355d8c4196f774c8b87ed1a8dd625" |
| 12 | SRC_URI = "git://github.com/KhronosGroup/Vulkan-Headers.git;branch=main;protocol=https" |
| 13 | |
| 14 | SRCREV = "7b3466a1f47a9251ac1113efbe022ff016e2f95b" |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | inherit cmake |
| 19 | |
| 20 | FILES:${PN} += "${datadir}/vulkan" |
| 21 | RDEPENDS:${PN} += "python3-core" |
| 22 | |
| 23 | # These recipes need to be updated in lockstep with each other: |
| 24 | # glslang, vulkan-headers, vulkan-loader, vulkan-tools, spirv-headers, spirv-tools, |
| 25 | # vulkan-validation-layers, vulkan-utility-libraries. |
| 26 | # The tags versions should always be sdk-x.y.z, as this is what |
| 27 | # upstream considers a release. |
| 28 | UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)" |