Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 1 | SUMMARY = "A commandline OMX player for the Raspberry Pi" |
| 2 | DESCRIPTION = "This player was developed as a testbed for the XBMC \ |
| 3 | Raspberry PI implementation and is quite handy to use standalone" |
| 4 | HOMEPAGE = "https://github.com/popcornmix/omxplayer" |
| 5 | SECTION = "console/utils" |
| 6 | |
| 7 | LICENSE = "GPLv2" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
| 9 | |
| 10 | DEPENDS = "libpcre libav virtual/egl boost freetype dbus openssl samba libssh" |
| 11 | PR = "r4" |
| 12 | |
| 13 | SRCREV = "8466acf65f5f444dfa22631fb83c07ac759c02a5" |
| 14 | SRC_URI = "git://github.com/popcornmix/omxplayer.git;protocol=git;branch=master \ |
| 15 | file://0001-Remove-Makefile.include-which-includes-hardcoded.patch \ |
| 16 | file://0002-Libraries-and-headers-from-ffmpeg-are-installed-in-u.patch \ |
| 17 | file://0003-Remove-strip-step-in-Makefile.patch \ |
| 18 | file://0004-Add-FFMPEG_EXTRA_CFLAGS-and-FFMPEG_EXTRA_LDFLAGS.patch \ |
| 19 | file://fix-tar-command-with-DIST.patch \ |
| 20 | file://use-native-pkg-config.patch \ |
| 21 | " |
| 22 | S = "${WORKDIR}/git" |
| 23 | |
| 24 | COMPATIBLE_MACHINE = "raspberrypi" |
| 25 | |
| 26 | inherit autotools-brokensep pkgconfig |
| 27 | |
| 28 | # Needed in ffmpeg configure |
| 29 | export TEMPDIR = "${S}/tmp" |
| 30 | |
| 31 | # Needed in Makefile.ffmpeg |
| 32 | export HOST = "${HOST_SYS}" |
| 33 | export WORK = "${S}" |
| 34 | export FLOAT = "${@bb.utils.contains("TUNE_FEATURES", "callconvention-hard", "hard", "softfp", d)}" |
| 35 | export FFMPEG_EXTRA_CFLAGS = "--sysroot=${STAGING_DIR_TARGET}" |
| 36 | export FFMPEG_EXTRA_LDFLAGS = "--sysroot=${STAGING_DIR_TARGET}" |
| 37 | |
| 38 | # Needed in top Makefile |
| 39 | export LDFLAGS = "-L${S}/ffmpeg_compiled/usr/lib \ |
| 40 | -L${STAGING_DIR_HOST}/lib \ |
| 41 | -L${STAGING_DIR_HOST}/usr/lib \ |
| 42 | " |
| 43 | export INCLUDES = "-isystem${STAGING_DIR_HOST}/usr/include/interface/vcos/pthreads \ |
| 44 | -isystem${STAGING_DIR_HOST}/usr/include/freetype2 \ |
| 45 | -isystem${STAGING_DIR_HOST}/usr/include/interface/vmcs_host/linux \ |
| 46 | -isystem${STAGING_DIR_HOST}/usr/include/dbus-1.0 \ |
| 47 | -isystem${STAGING_DIR_HOST}/usr/lib/dbus-1.0/include \ |
| 48 | " |
| 49 | export DIST = "${D}" |
| 50 | |
| 51 | do_compile() { |
| 52 | # Needed for compiler test in ffmpeg's configure |
| 53 | mkdir -p tmp |
| 54 | |
| 55 | oe_runmake ffmpeg |
| 56 | oe_runmake |
| 57 | } |
| 58 | |
| 59 | do_install() { |
| 60 | oe_runmake STRIP='echo skipping strip' dist |
| 61 | mkdir -p ${D}${datadir}/fonts/truetype/freefont/ |
| 62 | install ${S}/fonts/* ${D}${datadir}/fonts/truetype/freefont/ |
| 63 | } |
| 64 | |
| 65 | FILES_${PN} = "${bindir}/omxplayer* \ |
| 66 | ${libdir}/omxplayer/lib*${SOLIBS} \ |
| 67 | ${datadir}/fonts" |
| 68 | |
| 69 | FILES_${PN}-dev += "${libdir}/omxplayer/*.so" |
| 70 | |
| 71 | RDEPENDS_${PN} += "bash procps" |