blob: 18566284c093e9b37353005aeabd872eed6624ac [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Small and fast POSIX-compliant shell"
2HOMEPAGE = "http://gondor.apana.org.au/~herbert/dash/"
3SECTION = "System Environment/Shells"
4
5LICENSE = "BSD & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b5262b4a1a1bff72b48e935531976d2e"
7
8inherit autotools update-alternatives
9
10SRC_URI = "http://gondor.apana.org.au/~herbert/${BPN}/files/${BP}.tar.gz \
11 file://0001-Fix-printf-format-errors-with-clang.patch \
12 "
13SRC_URI[md5sum] = "8f485f126c05d0ab800e85abfe1987aa"
14SRC_URI[sha256sum] = "3c663919dc5c66ec991da14c7cf7e0be8ad00f3db73986a987c118862b5f6071"
15
16EXTRA_OECONF += "--bindir=${base_bindir}"
17
18ALTERNATIVE_${PN} = "sh"
19ALTERNATIVE_LINK_NAME[sh] = "${base_bindir}/sh"
20ALTERNATIVE_TARGET[sh] = "${base_bindir}/dash"
21ALTERNATIVE_PRIORITY = "10"
22
23pkg_postinst_${PN} () {
24 grep -q "^${base_bindir}/dash$" $D${sysconfdir}/shells || echo ${base_bindir}/dash >> $D${sysconfdir}/shells
25}
26
27pkg_postrm_${PN} () {
28 printf "$(grep -v "^${base_bindir}/dash$" $D${sysconfdir}/shells)\n" > $D${sysconfdir}/shells
29}