Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Lightweight crypto and SSL/TLS library" |
| 2 | DESCRIPTION = "mbedtls is a lean open source crypto library \ |
| 3 | for providing SSL and TLS support in your programs. It offers \ |
| 4 | an intuitive API and documented header files, so you can actually \ |
| 5 | understand what the code does. It features: \ |
| 6 | \ |
| 7 | - Symmetric algorithms, like AES, Blowfish, Triple-DES, DES, ARC4, \ |
| 8 | Camellia and XTEA \ |
| 9 | - Hash algorithms, like SHA-1, SHA-2, RIPEMD-160 and MD5 \ |
| 10 | - Entropy pool and random generators, like CTR-DRBG and HMAC-DRBG \ |
| 11 | - Public key algorithms, like RSA, Elliptic Curves, Diffie-Hellman, \ |
| 12 | ECDSA and ECDH \ |
| 13 | - SSL v3 and TLS 1.0, 1.1 and 1.2 \ |
| 14 | - Abstraction layers for ciphers, hashes, public key operations, \ |
| 15 | platform abstraction and threading \ |
| 16 | " |
| 17 | |
| 18 | HOMEPAGE = "https://tls.mbed.org/" |
| 19 | |
| 20 | LICENSE = "Apache-2.0" |
Andrew Geissler | 8fc454f | 2020-12-11 16:27:59 -0600 | [diff] [blame] | 21 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 22 | |
| 23 | SECTION = "libs" |
| 24 | |
Andrew Geissler | 8fc454f | 2020-12-11 16:27:59 -0600 | [diff] [blame] | 25 | S = "${WORKDIR}/git" |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 26 | SRCREV = "e483a77c85e1f9c1dd2eb1c5a8f552d2617fe400" |
Andrew Geissler | 72956ed | 2021-01-08 16:11:14 -0600 | [diff] [blame] | 27 | SRC_URI = "git://github.com/ARMmbed/mbedtls.git;protocol=https;branch=development" |
Andrew Geissler | 97771a3 | 2021-03-05 15:23:11 -0600 | [diff] [blame] | 28 | SRC_URI += "file://0001-ssl_tls-Increase-size-of-padbuf-to-64.patch" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 29 | |
| 30 | inherit cmake |
| 31 | |
| 32 | PACKAGECONFIG ??= "shared-libs programs" |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 33 | PACKAGECONFIG[shared-libs] = "-DUSE_SHARED_MBEDTLS_LIBRARY=ON,-DUSE_SHARED_MBEDTLS_LIBRARY=OFF" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 34 | PACKAGECONFIG[programs] = "-DENABLE_PROGRAMS=ON,-DENABLE_PROGRAMS=OFF" |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 35 | PACKAGECONFIG[werror] = "-DMBEDTLS_FATAL_WARNINGS=ON,-DMBEDTLS_FATAL_WARNINGS=OFF" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 36 | |
| 37 | EXTRA_OECMAKE = "-DENABLE_TESTING=OFF -DLIB_INSTALL_DIR:STRING=${libdir}" |
| 38 | |
| 39 | PROVIDES += "polarssl" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 40 | RPROVIDES:${PN} = "polarssl" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 41 | |
| 42 | PACKAGES =+ "${PN}-programs" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 43 | FILES:${PN}-programs = "${bindir}/" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 44 | |
| 45 | BBCLASSEXTEND = "native nativesdk" |