Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "ICE: Inter-Client Exchange library" |
| 2 | |
| 3 | DESCRIPTION = "The Inter-Client Exchange (ICE) protocol provides a \ |
| 4 | generic framework for building protocols on top of reliable, byte-stream \ |
| 5 | transport connections. It provides basic mechanisms for setting up and \ |
| 6 | shutting down connections, for performing authentication, for \ |
| 7 | negotiating versions, and for reporting errors. " |
| 8 | |
| 9 | require xorg-lib-common.inc |
| 10 | |
| 11 | LICENSE = "MIT" |
| 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=d162b1b3c6fa812da9d804dcf8584a93" |
| 13 | |
| 14 | DEPENDS += "xorgproto xtrans" |
| 15 | PROVIDES = "ice" |
| 16 | |
| 17 | PE = "1" |
| 18 | |
| 19 | XORG_PN = "libICE" |
| 20 | |
| 21 | BBCLASSEXTEND = "native nativesdk" |
| 22 | |
| 23 | SRC_URI[sha256sum] = "03e77afaf72942c7ac02ccebb19034e6e20f456dcf8dddadfeb572aa5ad3e451" |
| 24 | |
| 25 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}" |
| 26 | PACKAGECONFIG[arc4] = "ac_cv_lib_bsd_arc4random_buf=yes,ac_cv_lib_bsd_arc4random_buf=no,libbsd" |
| 27 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," |