Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "System Ready Scripts" |
| 2 | DESCRIPTION = "A collection of scripts to help with SystemReady compliance." |
| 3 | HOMEPAGE = "https://gitlab.arm.com/systemready/systemready-scripts" |
| 4 | |
| 5 | inherit native |
| 6 | |
| 7 | LICENSE = "BSD-3-Clause" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=85b7d439a311c22626c2e3f05daf628e" |
| 9 | |
| 10 | RDEPENDS:${PN} = "python3-packaging-native python3-pyyaml-native \ |
| 11 | python3-chardet-native python3-requests-native python3-construct-native \ |
| 12 | dtc-native python3-dtschema-wrapper-native" |
| 13 | |
| 14 | PV = "v2023.04" |
| 15 | S = "${WORKDIR}/git" |
| 16 | SRC_URI = "\ |
| 17 | git://git.gitlab.arm.com/systemready/systemready-scripts.git;protocol=https;nobranch=1 \ |
| 18 | file://0001-check-sr-results-Return-non-zero-exit-code-on-failur.patch \ |
| 19 | file://0002-check-sr-results-Device-tree-improvements.patch \ |
| 20 | " |
| 21 | |
| 22 | # The SRCREV is at the v2023.04 tag |
| 23 | SRCREV = "f8244ab8da09f9e6005ceff81ebb234f35a2a698" |
| 24 | |
| 25 | do_install() { |
| 26 | install -d ${D}/${libdir}/systemready_scripts |
| 27 | cp -r ${S}/* ${D}/${libdir}/systemready_scripts |
| 28 | } |
| 29 | |
| 30 | do_configure[noexec] = "1" |
| 31 | do_compile[noexec] = "1" |