Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 1 | SUMMARY = "Python Library for the Device Tree Compiler" |
| 2 | HOMEPAGE = "https://devicetree.org/" |
| 3 | DESCRIPTION = "A python library for the Device Tree Compiler, a tool used to manipulate Device Tree files which contain a data structure for describing hardware." |
| 4 | SECTION = "bootloader" |
| 5 | LICENSE = "GPL-2.0-only | BSD-2-Clause" |
| 6 | |
| 7 | DEPENDS = "flex-native bison-native swig-native python3-setuptools-scm-native libyaml dtc" |
| 8 | |
| 9 | SRC_URI = "git://git.kernel.org/pub/scm/utils/dtc/dtc.git;branch=master \ |
| 10 | file://0001-Revert-libfdt-overlay-make-overlay_get_target-public.patch \ |
| 11 | " |
| 12 | |
| 13 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)" |
| 14 | |
| 15 | LIC_FILES_CHKSUM = "file://pylibfdt/libfdt.i;beginline=1;endline=6;md5=afda088c974174a29108c8d80b5dce90" |
| 16 | |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 17 | SRCREV = "039a99414e778332d8f9c04cbd3072e1dcc62798" |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 18 | |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | PYPA_WHEEL = "${S}/dist/libfdt-1.6.2*.whl" |
| 22 | |
| 23 | inherit setuptools3 pkgconfig |
| 24 | |
| 25 | BBCLASSEXTEND = "native nativesdk" |