Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 1 | # Common code for dbus applications using c. |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 2 | inherit obmc-phosphor-systemd |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 3 | |
| 4 | DEPENDS += "glib-2.0" |
Brad Bishop | 09494ec | 2015-10-18 22:21:04 -0400 | [diff] [blame] | 5 | |
| 6 | INSTALL_NAME ?= "${PN}" |
| 7 | BIN_NAME ?= "${INSTALL_NAME}" |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 8 | |
| 9 | do_install_append() { |
| 10 | # install the binary |
| 11 | install -d ${D}${sbindir} |
Brad Bishop | 09494ec | 2015-10-18 22:21:04 -0400 | [diff] [blame] | 12 | install -m 0755 ${S}/${BIN_NAME} ${D}${sbindir}/${INSTALL_NAME} |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 13 | } |