Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | |
| 2 | inherit python-dir |
| 3 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 4 | PYTHON="${STAGING_BINDIR_NATIVE}/python-native/python" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 5 | # PYTHON_EXECUTABLE is used by cmake |
| 6 | PYTHON_EXECUTABLE="${PYTHON}" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 7 | EXTRANATIVEPATH += "python-native" |
| 8 | DEPENDS_append = " python-native " |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 9 | |
| 10 | # python-config and other scripts are using distutils modules |
| 11 | # which we patch to access these variables |
| 12 | export STAGING_INCDIR |
| 13 | export STAGING_LIBDIR |
| 14 | |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 15 | # Packages can use |
| 16 | # find_package(PythonInterp REQUIRED) |
| 17 | # find_package(PythonLibs REQUIRED) |
| 18 | # which ends up using libs/includes from build host |
| 19 | # Therefore pre-empt that effort |
| 20 | export PYTHON_LIBRARY="${STAGING_LIBDIR}/lib${PYTHON_DIR}${PYTHON_ABI}.so" |
| 21 | export PYTHON_INCLUDE_DIR="${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}" |
| 22 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 23 | # suppress host user's site-packages dirs. |
| 24 | export PYTHONNOUSERSITE = "1" |
| 25 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 26 | # autoconf macros will use their internal default preference otherwise |
| 27 | export PYTHON |