blob: b8ba5b05a3d013a0560ce19bd97fd50926359ce9 [file] [log] [blame]
Jordan Chang7cbff672023-03-03 15:53:28 +08001FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2
3SRC_URI:append = " file://uart-routing.sh \
4 file://use-socket.conf.in \
5 "
6
7RDEPENDS:${PN}:append = " bash"
8
9OBMC_CONSOLE_HOST_TTY:ncplite = "ttyS3"
10
11do_install:append() {
12 install -d ${D}${sbindir}
13 install -m 0755 ${WORKDIR}/uart-routing.sh -D ${D}${sbindir}/uart-routing.sh
14
15 install -d ${D}${systemd_system_unitdir}
16 install -m 0755 ${WORKDIR}/use-socket.conf.in -D ${D}${systemd_system_unitdir}/obmc-console-ssh@.service.d/use-socket.conf
17}