Jordan Chang | 7cbff67 | 2023-03-03 15:53:28 +0800 | [diff] [blame^] | 1 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" |
| 2 | |
| 3 | SRC_URI:append = " file://uart-routing.sh \ |
| 4 | file://use-socket.conf.in \ |
| 5 | " |
| 6 | |
| 7 | RDEPENDS:${PN}:append = " bash" |
| 8 | |
| 9 | OBMC_CONSOLE_HOST_TTY:ncplite = "ttyS3" |
| 10 | |
| 11 | do_install:append() { |
| 12 | install -d ${D}${sbindir} |
| 13 | install -m 0755 ${WORKDIR}/uart-routing.sh -D ${D}${sbindir}/uart-routing.sh |
| 14 | |
| 15 | install -d ${D}${systemd_system_unitdir} |
| 16 | install -m 0755 ${WORKDIR}/use-socket.conf.in -D ${D}${systemd_system_unitdir}/obmc-console-ssh@.service.d/use-socket.conf |
| 17 | } |