Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Library to handle input devices in Wayland compositors" |
| 2 | DESCRIPTION = "libinput is a library to handle input devices in Wayland \ |
| 3 | compositors and to provide a generic X.Org input driver. It provides \ |
| 4 | device detection, device handling, input device event processing and \ |
| 5 | abstraction so minimize the amount of custom input code compositors need to \ |
| 6 | provide the common set of functionality that users expect." |
| 7 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/libinput/" |
| 8 | SECTION = "libs" |
| 9 | |
| 10 | LICENSE = "MIT" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=1f2ea9ebff3a2c6d458faf58492efb63" |
| 12 | |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 13 | DEPENDS = "libevdev udev mtdev libcheck" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 14 | |
| 15 | SRC_URI = "http://www.freedesktop.org/software/${BPN}/${BP}.tar.xz \ |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 16 | file://run-ptest \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | file://determinism.patch \ |
| 18 | " |
Andrew Geissler | 635e0e4 | 2020-08-21 15:58:33 -0500 | [diff] [blame] | 19 | SRC_URI[md5sum] = "b518dae7f603040872739216971ee97b" |
| 20 | SRC_URI[sha256sum] = "83f6d0c94e5e0dd87094ce73f0edb631919617d24a60ee0ab9bd9197411d76e8" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 21 | |
| 22 | UPSTREAM_CHECK_REGEX = "libinput-(?P<pver>\d+\.\d+\.(?!9\d+)\d+)" |
| 23 | |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 24 | inherit meson pkgconfig lib_package ptest |
| 25 | |
| 26 | # Patch out build directory, otherwise it leaks into ptest binary |
| 27 | do_configure_append() { |
| 28 | sed -i -e "s,${WORKDIR},,g" config.h |
| 29 | if [ -e "litest-config.h" ]; then |
| 30 | sed -i -e "s,${WORKDIR},,g" litest-config.h |
| 31 | fi |
| 32 | } |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 33 | |
| 34 | PACKAGECONFIG ??= "" |
| 35 | PACKAGECONFIG[libwacom] = "-Dlibwacom=true,-Dlibwacom=false,libwacom" |
| 36 | PACKAGECONFIG[gui] = "-Ddebug-gui=true,-Ddebug-gui=false,cairo gtk+3" |
| 37 | |
| 38 | UDEVDIR = "`pkg-config --variable=udevdir udev`" |
| 39 | |
| 40 | EXTRA_OEMESON += "-Dudev-dir=${UDEVDIR} \ |
| 41 | -Ddocumentation=false \ |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 42 | ${@bb.utils.contains('PTEST_ENABLED', '1', '-Dtests=true -Dinstall-tests=true', '-Dtests=false -Dinstall-tests=false', d)} \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 43 | -Dzshcompletiondir=no" |
| 44 | |
| 45 | # package name changed in 1.8.1 upgrade: make sure package upgrades work |
| 46 | RPROVIDES_${PN} = "libinput" |
| 47 | RREPLACES_${PN} = "libinput" |
| 48 | RCONFLICTS_${PN} = "libinput" |
| 49 | |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 50 | FILES_${PN}-ptest += "${libexecdir}/libinput/libinput-test-suite" |