William A. Kennington III via Openembedded-devel | d25baec | 2019-01-15 16:48:56 -0800 | [diff] [blame] | 1 | SUMMARY = "C++11 command line parser" |
| 2 | DESCRIPTION = "A command line parser for C++11 and beyond that provides a rich feature set with a simple and intuitive interface." |
| 3 | HOMEPAGE = "https://github.com/CLIUtils/CLI11" |
| 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c271fee3ae28e11b24b97284d9f82887" |
| 6 | SRCREV = "bd4dc911847d0cde7a6b41dfa626a85aab213baf" |
| 7 | PV .= "+git${SRCPV}" |
| 8 | |
| 9 | SRC_URI += "gitsm://github.com/CLIUtils/CLI11" |
| 10 | |
| 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | inherit cmake |
| 14 | inherit ptest |
| 15 | |
| 16 | DEPENDS += "boost" |