Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "X.Org X server configuration file" |
| 2 | HOMEPAGE = "http://www.x.org" |
| 3 | SECTION = "x11/base" |
| 4 | LICENSE = "MIT-X" |
| 5 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
| 6 | PR = "r33" |
| 7 | |
| 8 | SRC_URI = "file://xorg.conf" |
| 9 | |
| 10 | SRC_URI_append_libc-musl = "\ |
| 11 | file://10-preload-modules.conf \ |
| 12 | " |
| 13 | |
| 14 | S = "${WORKDIR}" |
| 15 | |
| 16 | CONFFILES_${PN} = "${sysconfdir}/X11/xorg.conf" |
| 17 | CONFFILES_${PN}_append_libc-musl = " ${sysconfdir}/X11/xorg.conf.d/10-preload-modules.conf" |
| 18 | |
| 19 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 20 | ALLOW_EMPTY_${PN} = "1" |
| 21 | |
| 22 | do_install () { |
| 23 | if test -s ${WORKDIR}/xorg.conf; then |
| 24 | install -d ${D}/${sysconfdir}/X11 |
| 25 | install -m 0644 ${WORKDIR}/xorg.conf ${D}/${sysconfdir}/X11/ |
| 26 | fi |
| 27 | } |
| 28 | |
| 29 | do_install_append_libc-musl () { |
| 30 | install -Dm 0644 ${WORKDIR}/10-preload-modules.conf ${D}/${sysconfdir}/X11/xorg.conf.d/10-preload-modules.conf |
| 31 | } |