Andrew Geissler | f1e4406 | 2021-04-15 15:52:46 -0500 | [diff] [blame] | 1 | SUMMARY = "LibHTP is a security-aware parser for the HTTP protocol and the related bits and pieces." |
| 2 | |
| 3 | require suricata.inc |
| 4 | |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;beginline=1;endline=2;md5=596ab7963a1a0e5198e5a1c4aa621843" |
| 6 | |
| 7 | SRC_URI = "git://github.com/OISF/libhtp.git;protocol=https;branch=0.5.x" |
Andrew Geissler | 59125e0 | 2021-07-23 12:56:22 -0400 | [diff] [blame] | 8 | SRCREV = "fca44158911a1642880ea5c774151a33ad33d906" |
Andrew Geissler | f1e4406 | 2021-04-15 15:52:46 -0500 | [diff] [blame] | 9 | |
| 10 | DEPENDS = "zlib" |
| 11 | |
| 12 | inherit autotools-brokensep pkgconfig |
| 13 | |
| 14 | CFLAGS += "-D_DEFAULT_SOURCE" |
| 15 | |
| 16 | #S = "${WORKDIR}/suricata-${VER}/${BPN}" |
| 17 | |
| 18 | S = "${WORKDIR}/git" |
| 19 | |
| 20 | do_configure () { |
| 21 | cd ${S} |
| 22 | ./autogen.sh |
| 23 | oe_runconf |
| 24 | } |
| 25 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 26 | RDEPENDS:${PN} += "zlib" |
Andrew Geissler | f1e4406 | 2021-04-15 15:52:46 -0500 | [diff] [blame] | 27 | |