Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Convert text file line endings between CRLF and LF" |
| 2 | DESCRIPTION = "The Dos2unix package includes utilities dos2unix and \ |
| 3 | unix2dos to convert plain text files in DOS or Mac format to Unix \ |
| 4 | format and vice versa." |
| 5 | HOMEPAGE = "http://waterlan.home.xs4all.nl/dos2unix.html" |
| 6 | SECTION = "support" |
| 7 | |
| 8 | LICENSE = "BSD-2-Clause" |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 9 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=37f72246ce2aa2fce9482c10b1f2b502" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 10 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 11 | SRC_URI = "git://git.code.sf.net/p/dos2unix/dos2unix;branch=master" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | UPSTREAM_CHECK_GITTAGREGEX = "dos2unix-(?P<pver>(\d+(\.\d+)+))" |
| 13 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 14 | SRCREV = "b56a58584d3fef0720425ae154c2a4d80e6af6c5" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | |
| 16 | S = "${WORKDIR}/git/dos2unix" |
| 17 | |
| 18 | inherit gettext perlnative |
| 19 | |
| 20 | # The dos2unix NLS relies on po4a-native, while po4a recipe is |
| 21 | # provided by meta-perl layer, so make it optional here, you |
| 22 | # need have meta-perl in bblayers.conf before enabling nls in |
| 23 | # PACKAGECONFIG. |
| 24 | PACKAGECONFIG ??= "" |
| 25 | PACKAGECONFIG[nls] = "ENABLE_NLS=1,ENABLE_NLS=,po4a-native" |
| 26 | |
| 27 | EXTRA_OEMAKE = "${PACKAGECONFIG_CONFARGS} LDFLAGS_USER='${LDFLAGS}'" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 28 | EXTRA_OEMAKE:class-native = "ENABLE_NLS=" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 29 | |
| 30 | do_install () { |
| 31 | oe_runmake DESTDIR="${D}${base_prefix}" install |
| 32 | } |
| 33 | |
| 34 | BBCLASSEXTEND = "native nativesdk" |