Lancelot Kao | 96a7ee3 | 2021-02-22 18:50:48 -0600 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC Kudo System Power Control Service" |
| 2 | DESCRIPTION = "Phosphor OpenBMC Kudo System Power Control Daemon" |
| 3 | |
| 4 | PR = "r1" |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 7 | |
| 8 | inherit systemd |
| 9 | inherit obmc-phosphor-systemd |
| 10 | |
| 11 | DEPENDS += "systemd" |
Mohaimen Alsamarai | f59d017 | 2021-08-17 09:34:22 -0500 | [diff] [blame] | 12 | RDEPENDS:${PN} += "libsystemd" |
| 13 | RDEPENDS:${PN} += "bash" |
Lancelot Kao | 96a7ee3 | 2021-02-22 18:50:48 -0600 | [diff] [blame] | 14 | |
XP Chen | 9b90696 | 2021-05-06 15:23:19 -0500 | [diff] [blame] | 15 | SRC_URI = " \ |
Lancelot Kao | 96a7ee3 | 2021-02-22 18:50:48 -0600 | [diff] [blame] | 16 | file://init_once.sh \ |
| 17 | file://host-powerctrl.service \ |
| 18 | " |
| 19 | |
| 20 | SYSTEMD_PACKAGES = "${PN}" |
Mohaimen Alsamarai | f59d017 | 2021-08-17 09:34:22 -0500 | [diff] [blame] | 21 | SYSTEMD_SERVICE:${PN} = " \ |
Lancelot Kao | 96a7ee3 | 2021-02-22 18:50:48 -0600 | [diff] [blame] | 22 | host-powerctrl.service \ |
| 23 | " |
| 24 | |
| 25 | do_install () { |
Charles Boyer | 2adad36 | 2021-11-24 15:58:03 -0600 | [diff] [blame] | 26 | install -d ${D}${libexecdir}/${PN} |
| 27 | install -m 0755 ${WORKDIR}/init_once.sh ${D}${libexecdir}/${PN}/init_once.sh |
Lancelot Kao | 96a7ee3 | 2021-02-22 18:50:48 -0600 | [diff] [blame] | 28 | install -d ${D}${systemd_unitdir}/system/ |
| 29 | install -m 0644 ${WORKDIR}/host-powerctrl.service ${D}${systemd_unitdir}/system |
| 30 | } |