Brandon Kim | 236c94e | 2021-07-20 15:48:31 -0700 | [diff] [blame] | 1 | SUMMARY = "Dummy image uploader for sending debug binaries" |
| 2 | DESCRIPTION = "Dummy image uploader for sending debug binaries" |
| 3 | PR = "r1" |
| 4 | |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 7 | |
| 8 | inherit systemd |
| 9 | |
| 10 | SRC_URI += "file://config-dummy.json" |
| 11 | SRC_URI += "file://dummy-verify.service" |
| 12 | |
Willy Tu | 4dd03ca | 2021-08-06 09:37:35 -0700 | [diff] [blame] | 13 | FILES:${PN} += "${datadir}/phosphor-ipmi-flash" |
Brandon Kim | 236c94e | 2021-07-20 15:48:31 -0700 | [diff] [blame] | 14 | |
Willy Tu | 4dd03ca | 2021-08-06 09:37:35 -0700 | [diff] [blame] | 15 | SYSTEMD_SERVICE:${PN} += "dummy-verify.service" |
Brandon Kim | 236c94e | 2021-07-20 15:48:31 -0700 | [diff] [blame] | 16 | |
| 17 | do_install() { |
| 18 | install -d ${D}${datadir}/phosphor-ipmi-flash |
| 19 | install -m 0644 ${WORKDIR}/config-dummy.json ${D}${datadir}/phosphor-ipmi-flash |
| 20 | |
| 21 | install -d ${D}${systemd_system_unitdir} |
| 22 | install -m 0644 ${WORKDIR}/dummy-verify.service ${D}${systemd_system_unitdir} |
| 23 | } |