Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame^] | 1 | SUMMARY = "GNOME editor" |
| 2 | SECTION = "x11/gnome" |
| 3 | LICENSE = "GPLv2+" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=75859989545e37968a99b631ef42722e" |
| 5 | |
| 6 | GNOMEBASEBUILDCLASS = "meson" |
| 7 | |
| 8 | DEPENDS = " \ |
| 9 | gdk-pixbuf-native \ |
| 10 | gtk+3 \ |
| 11 | gsettings-desktop-schemas \ |
| 12 | libpeas \ |
| 13 | libsoup-2.4 \ |
| 14 | gspell \ |
| 15 | gtksourceview4 \ |
| 16 | tepl \ |
| 17 | " |
| 18 | |
| 19 | inherit gnomebase gsettings itstool gnome-help gobject-introspection gtk-doc vala gettext features_check mime-xdg python3targetconfig |
| 20 | |
| 21 | def gnome_verdir(v): |
| 22 | return oe.utils.trim_version(v, 1) |
| 23 | |
| 24 | REQUIRED_DISTRO_FEATURES = "x11" |
| 25 | |
| 26 | SRC_URI[archive.sha256sum] = "7a9b18b158808d1892989165f3706c4f1a282979079ab7458a79d3c24ad4deb5" |
| 27 | |
| 28 | # gobject-introspection is mandatory and cannot be configured |
| 29 | REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" |
| 30 | GIR_MESON_OPTION = "" |
| 31 | |
| 32 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 33 | |
| 34 | PACKAGES += "${PN}-python" |
| 35 | |
| 36 | FILES:${PN} += " \ |
| 37 | ${datadir}/dbus-1 \ |
| 38 | ${datadir}/metainfo \ |
| 39 | " |
| 40 | |
| 41 | FILES:${PN}-python += " \ |
| 42 | ${PYTHON_SITEPACKAGES_DIR} \ |
| 43 | " |
| 44 | |
| 45 | RDEPENDS:${PN} += "gsettings-desktop-schemas" |
| 46 | RRECOMMENDS:${PN} += "source-code-pro-fonts" |