Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Tracker miners and metadata extractors" |
| 2 | LICENSE = "GPLv2 & LGPLv2.1" |
| 3 | LIC_FILES_CHKSUM = " \ |
| 4 | file://COPYING.GPL;md5=ee31012bf90e7b8c108c69f197f3e3a4 \ |
| 5 | file://COPYING.LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \ |
| 6 | " |
| 7 | |
| 8 | DEPENDS = " \ |
| 9 | intltool-native \ |
| 10 | tracker \ |
| 11 | zlib \ |
| 12 | " |
| 13 | |
| 14 | GNOMEBASEBUILDCLASS = "meson" |
| 15 | |
| 16 | inherit gnomebase gsettings gobject-introspection vala bash-completion features_check |
| 17 | |
| 18 | SRC_URI += "file://0001-meson.build-Just-warn-if-we-build-without-libseccomp.patch" |
| 19 | SRC_URI[archive.sha256sum] = "44369f53e2edef41437406dbeecd477a97f8a9afdd9134832ea45d1ba2aa2c47" |
| 20 | |
| 21 | # gobject-introspection is mandatory and cannot be configured |
| 22 | REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" |
| 23 | GIR_MESON_OPTION = "" |
| 24 | |
| 25 | PACKAGECONFIG ??= " \ |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame^] | 26 | ${@bb.utils.contains("LICENSE_FLAGS_ACCEPTED", "commercial", "ffmpeg", "", d)} \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 27 | gexiv2 \ |
| 28 | gstreamer \ |
| 29 | icu \ |
| 30 | libexif \ |
| 31 | libgsf \ |
| 32 | jpeg \ |
| 33 | pdf \ |
| 34 | png \ |
| 35 | tiff \ |
| 36 | xml \ |
| 37 | ${@bb.utils.filter('DISTRO_FEATURES', 'seccomp', d)} \ |
| 38 | " |
| 39 | |
| 40 | PACKAGECONFIG[battery] = "-Dbattery_detection=upower,-Dbattery_detection=none,upower" |
| 41 | PACKAGECONFIG[ffmpeg] = ",,ffmpeg" |
| 42 | PACKAGECONFIG[gexiv2] = ",,gexiv2" |
| 43 | PACKAGECONFIG[gstreamer] = ",,gstreamer1.0 gstreamer1.0-plugins-base" |
| 44 | PACKAGECONFIG[gupnp] = ",,gupnp-dlna" |
| 45 | PACKAGECONFIG[gif] = "-Dgif=enabled,-Dgif=disabled,giflib" |
| 46 | PACKAGECONFIG[icu] = ",,icu" |
| 47 | PACKAGECONFIG[jpeg] = "-Djpeg=enabled,-Djpeg=disabled,jpeg" |
| 48 | PACKAGECONFIG[libexif] = "-Dexif=enabled,-Dexif=disabled,libexif" |
| 49 | PACKAGECONFIG[libgsf] = "-Dgsf=enabled,-Dgsf=disabled,libgsf" |
| 50 | PACKAGECONFIG[pdf] = "-Dpdf=enabled,-Dpdf=disabled,poppler" |
| 51 | PACKAGECONFIG[png] = "-Dpng=enabled,-Dpng=disabled,libpng" |
| 52 | PACKAGECONFIG[tiff] = "-Dtiff=enabled,-Dtiff=disabled,tiff" |
| 53 | PACKAGECONFIG[xml] = "-Dxml=enabled,-Dxml=disabled,libxml2" |
| 54 | PACKAGECONFIG[networkmanager] = "-Dnetwork_manager=enabled,-Dnetwork_manager=disabled,networkmanger" |
| 55 | |
| 56 | # For security reasons it is strongly recommended to set add meta-security in |
| 57 | # your layers and 'libseccomp' to PACKAGECONFIG". |
| 58 | PACKAGECONFIG[seccomp] = "-Dseccomp=true,-Dseccomp=false,libseccomp" |
| 59 | # not yet in meta-gnome |
| 60 | PACKAGECONFIG[rss] = "-Dminer_rss=true,-Dminer_rss=false,libgrss" |
| 61 | |
| 62 | EXTRA_OEMESON += " \ |
| 63 | -Dman=false \ |
| 64 | -Dsystemd_user_services=${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)} \ |
| 65 | -Dsystemd_user_services_dir=${systemd_user_unitdir} \ |
| 66 | " |
| 67 | |
| 68 | FILES:${PN} += " \ |
| 69 | ${datadir}/dbus-1 \ |
| 70 | ${datadir}/tracker3-miners \ |
| 71 | ${libdir}/tracker-miners-3.0 \ |
| 72 | ${systemd_user_unitdir} \ |
| 73 | " |