Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame^] | 1 | SUMMARY = "Cap'n Proto serialization/RPC system" |
| 2 | DESCRIPTION = "Cap’n Proto is an insanely fast data interchange format and capability-based RPC system. " |
| 3 | HOMEPAGE = "https://github.com/sandstorm-io/capnproto" |
| 4 | SECTION = "console/tools" |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://../LICENSE;md5=a05663ae6cca874123bf667a60dca8c9" |
| 7 | |
| 8 | SRC_URI = "git://github.com/sandstorm-io/capnproto.git;branch=release-${PV};protocol=https \ |
| 9 | " |
| 10 | SRCREV = "b49431c48d40490ef979247d308af63345376cee" |
| 11 | |
| 12 | S = "${WORKDIR}/git/c++" |
| 13 | |
| 14 | inherit cmake |
| 15 | |
| 16 | CXXFLAGS:append:mips = " -latomic" |
| 17 | CXXFLAGS:append:riscv32 = " -latomic" |
| 18 | |
| 19 | EXTRA_OECMAKE += "\ |
| 20 | -DBUILD_TESTING=OFF \ |
| 21 | " |
| 22 | |
| 23 | FILES:${PN}-compiler = "${bindir}" |
| 24 | |
| 25 | PACKAGE_BEFORE_PN = "${PN}-compiler" |
| 26 | RDEPENDS:${PN}-dev += "${PN}-compiler" |
| 27 | |
| 28 | BBCLASSEXTEND = "native nativesdk" |