Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "This is the io_uring library, liburing." |
| 2 | DESCRIPTION = "liburing provides helpers to setup and teardown io_uring \ |
| 3 | instances, and also a simplified interface for applications that don't need \ |
| 4 | (or want) to deal with the full kernel side implementation." |
| 5 | HOMEPAGE = "https://github.com/axboe/liburing" |
| 6 | BUGTRACKER = "https://github.com/axboe/liburing/issues" |
| 7 | SECTION = "libs" |
| 8 | |
| 9 | LICENSE = "LGPLv2.1 | MIT" |
| 10 | LIC_FILES_CHKSUM = "file://README;beginline=41;endline=44;md5=d51b5805e2a675685e6a66ca50904cf9" |
| 11 | |
| 12 | SRC_URI = "git://github.com/axboe/liburing.git;branch=master;protocol=https \ |
| 13 | file://0001-test-Use-syscall-wrappers-instead-of-using-syscall-2.patch \ |
| 14 | " |
| 15 | SRC_URI:append:libc-musl:riscv64 = " file://0001-do-not-build-examples.patch " |
| 16 | SRC_URI:append:libc-musl:riscv32 = " file://0001-do-not-build-examples.patch " |
| 17 | SRCREV = "41a61c97c2e3df4475c93fdf5026d575ce3f1377" |
| 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | DEPENDS:append:libc-musl = " libucontext" |
| 22 | XCFLAGS = "-pthread" |
| 23 | XCFLAGS:append:libc-musl = " -lucontext" |
| 24 | |
| 25 | EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR' 'LDFLAGS=${LDFLAGS}' 'XCFLAGS=${XCFLAGS}' 'BUILDDIR=${S}'" |
| 26 | do_configure() { |
| 27 | ${S}/configure --prefix=${prefix} |
| 28 | } |
| 29 | do_install () { |
| 30 | oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} INCLUDEDIR=${includedir} |
| 31 | } |