Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "ExtUtils::CppGuess - guess C++ compiler and flags" |
| 2 | DESCRIPTION = "ExtUtils::CppGuess attempts to guess the system's C++ \ |
| 3 | compiler that is compatible with the C compiler that your perl was built \ |
| 4 | with. \ |
| 5 | It can generate the necessary options to the Module::Build constructor or \ |
| 6 | to ExtUtils::MakeMaker's WriteMakefile function." |
| 7 | SECTION = "libs" |
| 8 | |
| 9 | HOMEPAGE = "http://search.cpan.org/~smueller/ExtUtils-CppGuess/" |
| 10 | |
| 11 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 12 | LIC_FILES_CHKSUM = "file://README;beginline=81;endline=84;md5=84c0390b90ea8c6702ce659b67bed699" |
| 13 | |
| 14 | SRC_URI = "${CPAN_MIRROR}/authors/id/E/ET/ETJ/ExtUtils-CppGuess-${PV}.tar.gz" |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "f96c48984eb6d8efb7d933b34f361d0c8b38335e3e5382e9aeccc0aa519a002c" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 16 | |
| 17 | S = "${WORKDIR}/ExtUtils-CppGuess-${PV}" |
| 18 | |
| 19 | inherit cpan |
| 20 | |
| 21 | do_install () { |
| 22 | cpan_do_install |
| 23 | } |
| 24 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 25 | RDEPENDS:${PN} = " libcapture-tiny-perl \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 26 | perl-module-scalar-util \ |
| 27 | perl-module-io-file \ |
| 28 | perl-module-extutils-makemaker \ |
| 29 | perl-module-file-spec \ |
| 30 | perl-module-exporter \ |
| 31 | perl-module-carp \ |
| 32 | perl-module-file-temp \ |
| 33 | perl-module-lib \ |
| 34 | " |
| 35 | |
| 36 | BBCLASSEXTEND = "native" |