Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Wraps the best available JSON implementation available in a common interface" |
| 2 | DESCRIPTION = "Anyjson loads whichever is the fastest JSON module installed and \ |
| 3 | provides a uniform API regardless of which JSON implementation is used." |
| 4 | HOMEPAGE = "https://bitbucket.org/runeh/anyjson" |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=989aa97e73c912a83a3c873fa11deb08" |
| 7 | |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 8 | inherit pypi setuptools3 ptest |
| 9 | |
| 10 | SRC_URI += " \ |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 11 | file://0001-setup.py-Do-not-use-2to3.patch \ |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 12 | file://run-ptest \ |
| 13 | " |
| 14 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 15 | RDEPENDS:${PN}-ptest += " \ |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 16 | ${PYTHON_PN}-pytest \ |
| 17 | ${PYTHON_PN}-nose \ |
| 18 | " |
| 19 | |
| 20 | do_install_ptest() { |
| 21 | install -d ${D}${PTEST_PATH}/tests |
| 22 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 23 | } |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 24 | |
| 25 | SRC_URI[md5sum] = "2ea28d6ec311aeeebaf993cb3008b27c" |
| 26 | SRC_URI[sha256sum] = "37812d863c9ad3e35c0734c42e0bf0320ce8c3bed82cd20ad54cb34d158157ba" |
| 27 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 28 | RDEPENDS:${PN} += "${PYTHON_PN}-simplejson" |