Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame^] | 1 | SUMMARY = "A python package that provides useful locks." |
| 2 | HOMEPAGE = "https://github.com/harlowja/fasteners" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4476c4be31402271e101d9a4a3430d52" |
| 5 | |
| 6 | SRC_URI[sha256sum] = "a9a42a208573d4074c77d041447336cf4e3c1389a256fd3e113ef59cf29b7980" |
| 7 | |
| 8 | inherit pypi setuptools3 |
| 9 | |
| 10 | RDEPENDS:${PN} += "\ |
| 11 | ${PYTHON_PN}-logging \ |
| 12 | ${PYTHON_PN}-fcntl \ |
| 13 | " |
| 14 | |
| 15 | do_compile:prepend() { |
| 16 | echo "from setuptools import setup" > ${S}/setup.py |
| 17 | echo "setup()" >> ${S}/setup.py |
| 18 | } |