Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "A coroutine-based Python networking library" |
| 2 | DESCRIPTION = "gevent is a coroutine-based Python networking library that uses greenlet to provide \ |
| 3 | a high-level synchronous API on top of the libevent event loop." |
| 4 | HOMEPAGE = "http://www.gevent.org" |
| 5 | LICENSE = "MIT & Python-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4de99aac27b470c29c6c309e0c279b65" |
| 7 | DEPENDS += "${PYTHON_PN}-greenlet libev c-ares" |
| 8 | |
| 9 | RDEPENDS:${PN} = "${PYTHON_PN}-greenlet \ |
| 10 | ${PYTHON_PN}-mime \ |
| 11 | ${PYTHON_PN}-pprint \ |
| 12 | " |
| 13 | |
| 14 | SRC_URI[sha256sum] = "f48b64578c367b91fa793bf8eaaaf4995cb93c8bc45860e473bf868070ad094e" |
| 15 | |
| 16 | inherit pypi setuptools3 |
| 17 | |
| 18 | # Don't embed libraries, link to the system instead |
| 19 | export GEVENTSETUP_EMBED = "0" |
| 20 | |
| 21 | # Delete the embedded copies of libraries so we can't accidentally link to them |
| 22 | do_configure:append() { |
| 23 | rm -rf ${S}/deps |
| 24 | } |