Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Physical quantities module" |
| 2 | DESCRIPTION = "Physical quantities Python module" |
| 3 | HOMEPAGE = "https://github.com/hgrecco/pint" |
| 4 | SECTION = "devel/python" |
| 5 | |
| 6 | LICENSE = "BSD-3-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b" |
| 8 | |
| 9 | PYPI_PACKAGE := "Pint" |
| 10 | |
| 11 | inherit pypi ptest setuptools3 |
| 12 | |
| 13 | SRC_URI[sha256sum] = "8c4bce884c269051feb7abc69dbfd18403c0c764abc83da132e8a7222f8ba801" |
| 14 | |
| 15 | DEPENDS += "python3-setuptools-scm-native" |
| 16 | |
| 17 | BBCLASSEXTEND = "native nativesdk" |
| 18 | |
| 19 | SRC_URI += " \ |
| 20 | file://run-ptest \ |
| 21 | " |
| 22 | |
| 23 | RDEPENDS:${PN} += " \ |
| 24 | ${PYTHON_PN}-setuptools \ |
| 25 | ${PYTHON_PN}-packaging \ |
| 26 | " |
| 27 | |
| 28 | RDEPENDS:${PN}-ptest += " \ |
| 29 | ${PYTHON_PN}-pytest \ |
| 30 | " |
| 31 | |
| 32 | do_install_ptest() { |
| 33 | install -d ${D}${PTEST_PATH}/testsuite |
| 34 | cp -rf ${S}/pint/testsuite/* ${D}${PTEST_PATH}/testsuite/ |
| 35 | } |