George Hung | 3909013 | 2020-05-12 16:56:27 +0800 | [diff] [blame] | 1 | SUMMARY = "Power Cycle by Hotswap Controller" |
| 2 | DESCRIPTION = "Power Cycle by Hotswap Controller Daemon" |
| 3 | PR = "r1" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 6 | |
| 7 | inherit systemd |
| 8 | |
| 9 | DEPENDS += "systemd" |
Brandon Kim | 1e42709 | 2021-08-10 15:46:03 -0700 | [diff] [blame] | 10 | RDEPENDS:${PN} += "bash" |
| 11 | RDEPENDS:${PN} += "libgpiod-tools" |
George Hung | 3909013 | 2020-05-12 16:56:27 +0800 | [diff] [blame] | 12 | |
Brandon Kim | c7f50e7 | 2020-08-12 19:15:12 -0700 | [diff] [blame] | 13 | SRC_URI = " file://hotswap-power-cycle.service \ |
| 14 | file://tray_powercycle.sh \ |
| 15 | " |
George Hung | 3909013 | 2020-05-12 16:56:27 +0800 | [diff] [blame] | 16 | |
| 17 | do_install() { |
| 18 | install -d ${D}${systemd_system_unitdir} |
| 19 | install -m 0644 ${WORKDIR}/hotswap-power-cycle.service ${D}${systemd_system_unitdir} |
Brandon Kim | c7f50e7 | 2020-08-12 19:15:12 -0700 | [diff] [blame] | 20 | |
| 21 | install -d ${D}${bindir} |
| 22 | install -m 0755 ${WORKDIR}/tray_powercycle.sh ${D}${bindir} |
George Hung | 3909013 | 2020-05-12 16:56:27 +0800 | [diff] [blame] | 23 | } |
| 24 | |
| 25 | SYSTEMD_PACKAGES = "${PN}" |
Brandon Kim | 1e42709 | 2021-08-10 15:46:03 -0700 | [diff] [blame] | 26 | SYSTEMD_SERVICE:${PN} = "hotswap-power-cycle.service" |
George Hung | 3909013 | 2020-05-12 16:56:27 +0800 | [diff] [blame] | 27 | |