Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame^] | 1 | SUMMARY = "RISC-V Open Source Supervisor Binary Interface (OpenSBI)" |
| 2 | DESCRIPTION = "OpenSBI aims to provide an open-source and extensible implementation of the RISC-V SBI specification for a platform specific firmware (M-mode) and a general purpose OS, hypervisor or bootloader (S-mode or HS-mode). OpenSBI implementation can be easily extended by RISC-V platform or System-on-Chip vendors to fit a particular hadware configuration." |
| 3 | HOMEPAGE = "https://github.com/riscv/opensbi" |
| 4 | LICENSE = "BSD-2-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING.BSD;md5=42dd9555eb177f35150cf9aa240b61e5" |
| 6 | |
| 7 | require opensbi-payloads.inc |
| 8 | |
| 9 | inherit autotools-brokensep deploy |
| 10 | |
| 11 | SRCREV = "ce4c0188d96b2c20c2e08d24646a5e517fe15a4b" |
| 12 | SRC_URI = "git://github.com/riscv/opensbi.git;branch=master;protocol=https \ |
| 13 | " |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | EXTRA_OEMAKE += "PLATFORM=${RISCV_SBI_PLAT} I=${D} FW_PIC=n CLANG_TARGET= " |
| 18 | # If RISCV_SBI_PAYLOAD is set then include it as a payload |
| 19 | EXTRA_OEMAKE:append = " ${@riscv_get_extra_oemake_image(d)}" |
| 20 | EXTRA_OEMAKE:append = " ${@riscv_get_extra_oemake_fdt(d)}" |
| 21 | |
| 22 | # Required if specifying a custom payload |
| 23 | do_compile[depends] += "${@riscv_get_do_compile_depends(d)}" |
| 24 | |
| 25 | do_install:append() { |
| 26 | # In the future these might be required as a dependency for other packages. |
| 27 | # At the moment just delete them to avoid warnings |
| 28 | rm -r ${D}/include |
| 29 | rm -r ${D}/lib* |
| 30 | rm -r ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/payloads |
| 31 | } |
| 32 | |
| 33 | do_deploy () { |
| 34 | install -m 755 ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_payload.* ${DEPLOYDIR}/ |
| 35 | install -m 755 ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_jump.* ${DEPLOYDIR}/ |
| 36 | install -m 755 ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_dynamic.* ${DEPLOYDIR}/ |
| 37 | } |
| 38 | |
| 39 | addtask deploy before do_build after do_install |
| 40 | |
| 41 | FILES:${PN} += "/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_jump.*" |
| 42 | FILES:${PN} += "/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_payload.*" |
| 43 | FILES:${PN} += "/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_dynamic.*" |
| 44 | |
| 45 | COMPATIBLE_HOST = "(riscv64|riscv32).*" |
| 46 | INHIBIT_PACKAGE_STRIP = "1" |
| 47 | |
| 48 | SECURITY_CFLAGS = "" |