Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "tool for automating interactive applications according to a script" |
| 2 | DESCRIPTION = "Expect is a tool for automating interactive applications according to a script. \ |
| 3 | Following the script, Expect knows what can be expected from a program and what \ |
| 4 | the correct response should be. Expect is also useful for testing these same \ |
| 5 | applications. And by adding Tk, you can also wrap interactive applications in \ |
| 6 | X11 GUIs. An interpreted language provides branching and high-level control \ |
| 7 | structures to direct the dialogue. In addition, the user can take control and \ |
| 8 | interact directly when desired, afterward returning control to the script. \ |
| 9 | " |
| 10 | HOMEPAGE = "http://sourceforge.net/projects/expect/" |
| 11 | LICENSE = "PD" |
| 12 | SECTION = "devel" |
| 13 | |
| 14 | LIC_FILES_CHKSUM = "file://license.terms;md5=fbf2de7e9102505b1439db06fc36ce5c" |
| 15 | |
| 16 | DEPENDS += "tcl" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 17 | RDEPENDS:${PN} = "tcl" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 18 | |
| 19 | inherit autotools update-alternatives |
| 20 | |
| 21 | SRC_URI = "${SOURCEFORGE_MIRROR}/expect/Expect/${PV}/${BPN}${PV}.tar.gz \ |
| 22 | file://0001-configure.in.patch \ |
| 23 | file://0002-tcl.m4.patch \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 24 | file://0001-expect-install-scripts-without-using-the-fixline1-tc.patch \ |
| 25 | file://0001-Resolve-string-formatting-issues.patch \ |
| 26 | file://0001-expect-Fix-segfaults-if-Tcl-is-built-with-stubs-and-.patch \ |
Brad Bishop | 00e122a | 2019-10-05 11:10:57 -0400 | [diff] [blame] | 27 | file://0001-exp_main_sub.c-Use-PATH_MAX-for-path.patch \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 28 | " |
| 29 | SRC_URI[md5sum] = "00fce8de158422f5ccd2666512329bd2" |
| 30 | SRC_URI[sha256sum] = "49a7da83b0bdd9f46d04a04deec19c7767bb9a323e40c4781f89caf760b92c34" |
| 31 | |
| 32 | UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/expect/files/Expect/" |
| 33 | UPSTREAM_CHECK_REGEX = "/Expect/(?P<pver>(\d+[\.\-_]*)+)/" |
| 34 | |
| 35 | S = "${WORKDIR}/${BPN}${PV}" |
| 36 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 37 | do_install:append() { |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 38 | install -d ${D}${libdir} |
| 39 | install -m 0755 ${D}${libdir}/expect${PV}/libexpect*.so ${D}${libdir}/ |
| 40 | install -m 0755 ${S}/fixline1 ${D}${libdir}/expect${PV}/ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 41 | rm ${D}${libdir}/expect${PV}/libexpect*.so |
| 42 | sed -e 's|$dir|${libdir}|' -i ${D}${libdir}/expect${PV}/pkgIndex.tcl |
| 43 | } |
| 44 | |
| 45 | # Apparently the public Tcl headers are only in /usr/include/tcl8.6 |
Brad Bishop | 00e122a | 2019-10-05 11:10:57 -0400 | [diff] [blame] | 46 | # when building for the target and nativesdk. |
| 47 | TCL_INCLUDE_PATH = "--with-tclinclude=${STAGING_INCDIR}/tcl8.6" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 48 | TCL_INCLUDE_PATH:class-native = "" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 49 | |
| 50 | EXTRA_OECONF += "--with-tcl=${STAGING_LIBDIR} \ |
| 51 | --enable-shared \ |
| 52 | --enable-threads \ |
| 53 | --disable-rpath \ |
| 54 | ${TCL_INCLUDE_PATH} \ |
| 55 | " |
| 56 | EXTRA_OEMAKE_install = " 'SCRIPTS=' " |
| 57 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 58 | ALTERNATIVE:${PN} = "mkpasswd" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 59 | ALTERNATIVE_LINK_NAME[mkpasswd] = "${bindir}/mkpasswd" |
| 60 | # Use lower priority than busybox's mkpasswd (created when built with CONFIG_CRYPTPW) |
| 61 | ALTERNATIVE_PRIORITY[mkpasswd] = "40" |
| 62 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 63 | FILES:${PN}-dev = "${libdir_native}/expect${PV}/libexpect*.so \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 64 | ${includedir}/expect.h \ |
| 65 | ${includedir}/expect_tcl.h \ |
| 66 | ${includedir}/expect_comm.h \ |
| 67 | ${includedir}/tcldbg.h \ |
| 68 | ${includedir}/*.h \ |
| 69 | " |
| 70 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 71 | FILES:${PN} += "${libdir}/libexpect${PV}.so \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 72 | ${libdir}/expect${PV}/* \ |
| 73 | " |
| 74 | |
| 75 | BBCLASSEXTEND = "native nativesdk" |