Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame^] | 1 | SUMMARY = "Tools to generate block map (AKA bmap) and flash images using bmap" |
| 2 | DESCRIPTION = "Bmap-tools - tools to generate block map (AKA bmap) and flash images using \ |
| 3 | bmap. Bmaptool is a generic tool for creating the block map (bmap) for a file, \ |
| 4 | and copying files using the block map. The idea is that large file containing \ |
| 5 | unused blocks, like raw system image files, can be copied or flashed a lot \ |
| 6 | faster with bmaptool than with traditional tools like "dd" or "cp"." |
| 7 | HOMEPAGE = "https://github.com/01org/bmap-tools" |
| 8 | SECTION = "console/utils" |
| 9 | LICENSE = "GPL-2.0-only" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 11 | |
| 12 | SRC_URI = "git://github.com/intel/${BPN};branch=master;protocol=https" |
| 13 | |
| 14 | SRCREV = "c0673962a8ec1624b5189dc1d24f33fe4f06785a" |
| 15 | S = "${WORKDIR}/git" |
| 16 | BASEVER = "3.6" |
| 17 | PV = "${BASEVER}+git${SRCPV}" |
| 18 | |
| 19 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)" |
| 20 | |
| 21 | # Need df from coreutils |
| 22 | RDEPENDS:${PN} = "python3-core python3-compression python3-mmap python3-setuptools python3-fcntl python3-six coreutils" |
| 23 | |
| 24 | inherit python3native |
| 25 | inherit setuptools3 |
| 26 | |
| 27 | PIP_INSTALL_PACKAGE = "bmap_tools" |
| 28 | PYPA_WHEEL = "${PIP_INSTALL_DIST_PATH}/${PIP_INSTALL_PACKAGE}-${BASEVER}-*.whl" |
| 29 | |
| 30 | BBCLASSEXTEND = "native nativesdk" |