Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame^] | 1 | SUMMARY = "Userspace library to access USB (version 1.0)" |
| 2 | DESCRIPTION = "A cross-platform library to access USB devices from Linux, \ |
| 3 | macOS, Windows, OpenBSD/NetBSD, Haiku and Solaris userspace." |
| 4 | HOMEPAGE = "https://libusb.info" |
| 5 | BUGTRACKER = "http://www.libusb.org/report" |
| 6 | SECTION = "libs" |
| 7 | |
| 8 | LICENSE = "LGPL-2.1-or-later" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24" |
| 10 | |
| 11 | BBCLASSEXTEND = "native nativesdk" |
| 12 | |
| 13 | SRC_URI = "https://github.com/libusb/libusb/releases/download/v${PV}/libusb-${PV}.tar.bz2 \ |
| 14 | file://run-ptest \ |
| 15 | " |
| 16 | |
| 17 | UPSTREAM_CHECK_URI = "https://github.com/libusb/libusb/releases" |
| 18 | |
| 19 | SRC_URI[sha256sum] = "8a28ef197a797ebac2702f095e81975e2b02b2eeff2774fa909c78a74ef50849" |
| 20 | |
| 21 | S = "${WORKDIR}/libusb-${PV}" |
| 22 | |
| 23 | inherit autotools pkgconfig ptest |
| 24 | |
| 25 | PACKAGECONFIG:class-target ??= "udev" |
| 26 | PACKAGECONFIG[udev] = "--enable-udev,--disable-udev,udev" |
| 27 | |
| 28 | EXTRA_OECONF = "--libdir=${base_libdir}" |
| 29 | |
| 30 | do_install:append() { |
| 31 | install -d ${D}${libdir} |
| 32 | if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then |
| 33 | mv ${D}${base_libdir}/pkgconfig ${D}${libdir} |
| 34 | fi |
| 35 | } |
| 36 | |
| 37 | do_compile_ptest() { |
| 38 | oe_runmake -C tests stress |
| 39 | } |
| 40 | |
| 41 | do_install_ptest() { |
| 42 | install -m 755 ${B}/tests/.libs/stress ${D}${PTEST_PATH} |
| 43 | } |
| 44 | |
| 45 | FILES:${PN} += "${base_libdir}/*.so.*" |
| 46 | |
| 47 | FILES:${PN}-dev += "${base_libdir}/*.so ${base_libdir}/*.la" |