blob: c35c77b125c01276ebfd97e231ac4f7dcb513aa0 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "open-source formatting library for C++"
2DESCRIPTION = "{fmt} is an open-source formatting library for C++. It can be used as a safe and fast alternative to (s)printf and iostreams."
3HOMEPAGE = "https://fmt.dev"
Brad Bishop7e36d532019-09-16 07:44:26 -04004LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=af88d758f75f3c5c48a967501f24384b"
Brad Bishop26bdd442019-08-16 17:08:17 -04006
7SRC_URI += "git://github.com/fmtlib/fmt"
Brad Bishop7e36d532019-09-16 07:44:26 -04008SRCREV = "7512a55aa3ae309587ca89668ef9ec4074a51a1f"
Brad Bishop26bdd442019-08-16 17:08:17 -04009
10S = "${WORKDIR}/git"
11
12inherit cmake
13inherit ptest
14
15EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON"