blob: 57e979e909c3fea6b46a9f0ad8502c900c3fed15 [file] [log] [blame]
Patrick Williams73bd93f2024-02-20 08:07:48 -06001SUMMARY = "Simple powerful testing with python"
2HOMEPAGE = "https://pypi.org/project/pytest/"
3DESCRIPTION = "The pytest framework makes it easy to write small tests, yet scales to support complex functional testing for applications and libraries."
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=bd27e41b6550fe0fc45356d1d81ee37c"
7
Patrick Williams39653562024-03-01 08:54:02 -06008SRC_URI[sha256sum] = "d4051d623a2e0b7e51960ba963193b09ce6daeb9759a451844a21e4ddedfc1bd"
Patrick Williams73bd93f2024-02-20 08:07:48 -06009
10DEPENDS += "python3-setuptools-scm-native"
11
12inherit update-alternatives pypi python_setuptools_build_meta
13
14RDEPENDS:${PN} += " \
15 python3-atomicwrites \
16 python3-attrs \
17 python3-debugger \
18 python3-doctest \
19 python3-importlib-metadata \
20 python3-iniconfig \
21 python3-json \
22 python3-more-itertools \
23 python3-packaging \
24 python3-pathlib2 \
25 python3-pluggy \
26 python3-py \
27 python3-setuptools \
28 python3-six \
29 python3-tomllib \
30 python3-wcwidth \
31"
32
33ALTERNATIVE:${PN} += "py.test pytest"
34
35NATIVE_LINK_NAME[pytest] = "${bindir}/pytest"
36ALTERNATIVE_TARGET[pytest] = "${bindir}/pytest"
37
38ALTERNATIVE_LINK_NAME[py.test] = "${bindir}/py.test"
39ALTERNATIVE_TARGET[py.test] = "${bindir}/py.test"
40
41BBCLASSEXTEND = "native nativesdk"